Snip for MacOS

Note: the earliest version of MacOS that our app supports is MacOS Sierra 10.12 If you are running an earlier version of MacOS and would like to use Snip, please try our web app, Snip Notes.